Setup on synology #338
Replies: 6 comments 5 replies
|
Hi! Are you trying to open RomM in a browser or that 404 appears without reason? What I see there is that somehow the frontend is requesting the root path (the home page) before the backend is setup. But the last lines means that backend started properly and the migrations (database setup) went well. Did you tried to open RomM after that migrations were done? |
|
What are this errors "172.21.0.1:54098 - "GET / HTTP/1.1" 404 Not Found" ? |
|
I can't really tell, because the only endpoint is called when you enter RomM is So I really don't know why that is happening tho. We are opening the official discord server today, so you can try to post there the problem and maybe someone else using synology can help 😞 |
|
@alexandru-andronache Can you post screenshots of the requests tab in your developer tools as you reload RomM, and the responses you're getting from the server? As well as the docker logs for that same period of time. I'd like to see all the calls it's making, and you're welcome to black out any URL hosts (just not paths). |
|
Resolved in the RomM official discord. The problem was the docker-compose container port definition. |
|
@zurdi15 I'm having a similar issue. Could you be more specific about how the port definition was an issue? |
Uh oh!
There was an error while loading. Please reload this page.
Hi,
I'm trying to setup romm on a synology machine using docker.
This is the YAML configuration that i'm using:
the docket image starts but i get this error:
this is the log:
Any idea what is wrong?
All reactions